Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Gez

Pages: [1]
1
Closed Bug Reports and Feature Requests / Valgrind error log
« on: May 20, 2013, 12:46:55 pm »
I've noticed there must be memory leaks since the memory footprint does not lower much when closing an archive. After setting up a Linux box to compile SLADE and run it through Valgrind, I got the following journal: http://pastebin.com/WAyKfUnj

2
Closed Bug Reports and Feature Requests / Texture editor issues
« on: April 06, 2012, 04:14:38 pm »
See this thread for details.

3
Every time a new archive tab is opened, the AudioEntryPanel constructor calls the wxMediaCtrl constructor and this causes the name wxAMMediaBackend to be logged.

Is there any way to avoid that, short of editing wxWidgets directly and recompiling it?

4
SLADE General Discussion / FluidSynth
« on: February 26, 2012, 08:52:16 pm »
About the r1172 message: I'd rather not drop it, though it can certainly be made optional. (Like ZDoom does.) First it sounds nicer than the default Windows MIDI player, and besides it's the only way to get proper playback of Doom 64's MIDI lumps (as it uses a custom SF2 soundfont).

5
Pretty simple. Start SLADE, make your computer hibernate, wake it up, then open some archive with audio stuff in it (either MIDI or digitized) and try to get them to play. It stays silent, nothing happens. It's like SLADE lost the connection to its audio lib.

I'm not sure how to go on addressing that.

Pages: [1]