Author Topic: 3d mode very slow  (Read 2137 times)

Catoptromancy

3d mode very slow
« on: February 11, 2013, 09:01:59 am »
3d mode is just barely fast enough to be usable. glboom-plus and Quakelive run flawlessly.

Not sure what is going on, but I am sure this can be sped up quite a bit somehow.

sirjuddington

Re: 3d mode very slow
« Reply #1 on: February 11, 2013, 09:35:49 am »
It's never going to be as fast as in game (or slade2 even) since I'm not using nodes at all, so there is no (real) vis checking. It's plenty usable on my laptop with a crappy intel hd 3000, as long as the view distance is turned down on large/complex maps.

Catoptromancy

Re: 3d mode very slow
« Reply #2 on: February 13, 2013, 11:06:01 pm »
Still testing, there is some way to make it almost completely lock up...havent quite figured out how to reproduce.

Actual bug report, render distance does not apply. Any change in render distance settings does nothing and always resets to highest.

Catoptromancy

Re: 3d mode very slow
« Reply #3 on: March 23, 2013, 01:42:54 am »
It's the mouse code! I turn render and thing view all the way up to infinite. I zoom in and out and strafe around smoothly and flawlessly. Render and thing view turned all the way down is just as smooth.

Only when I move the mouse the screen gets extremely choppy.
« Last Edit: March 23, 2013, 01:54:59 am by Catoptromancy »

Gez

Re: 3d mode very slow
« Reply #4 on: January 16, 2014, 11:36:41 pm »
If this is still valid, please reopen on the Github issue tracker.